Исправление расчета пособия Больничный лист по уходу за больным ребенком в ЗУП 3.1.14.208-237

Публикация № 1310159

Учет и отчетность - Зарплата

исправление больничного в том числе за счет федерального бюджета уход больным ребенком расширение

В документе Больничный лист с кодом "(09, 12, 13, 14, 15) Уход за больным ребенком" после расчета на вкладке "Начислено(подробно)" в колонке "В том числе за счет федерального бюджета" появляется сумма. Суммы в колонке быть не должно.

Софинансирования федерального бюджета нет. Только пострадавшим от ЧАЭС. Если оставить сумму, то в реестре пособий за счет ФСС она попадает в "Сверхнормы". При этом поле "Фед. бюджет" пусто.

В общем, в ходе реализации нового функционала https://buhexpert8.ru/obuchenie-1s/1s-zup-8-3/novyj-raschet-bolnichnogo-ne-nizhe-mrot.html  допущена ошибка в общем модуле УчетПособийСоциальногоСтрахования в процедуре РассчитатьПособиеПоНетрудоспособности 

Скачать файлы

Наименование Файл Версия Размер
Исправление ошибки ЗУП 3.1.14.208-237

.cfe 6,07Kb
14.10.20
16
.cfe 6,07Kb 16 Скачать бесплатно
Листинг процедуры с исправлением в ОбщийМодуль.УчетПособийСоциальногоСтрахования

.txt 14,92Kb
14.10.20
10
.txt 14,92Kb 10 Скачать бесплатно

Специальные предложения

Комментарии
В избранное Подписаться на ответы Сортировка: Древо развёрнутое
Свернуть все
1. user750336 15.10.20 13:45 Сейчас в теме
Автор, а у вас прямо на всех больничных по уходу за ребенком возникает сумма за счет ФБ? Ввела у себя в базе несколько примеров, и ни в одном не получилось добиться того, чтобы эта сумма заполнилась, если не устанавливать использование льгот (для чернобыльцев и т.д.). Релиз 3.1.14.237. Может быть, всё-таки исходные данные заданы некорректно (стажи или льготы)? Да и способ исправления ошибки, честно говоря, вызывает сомнение, особенно в варианте с расширением. Просто для всех строк начислений во всех больничных (со льготами и без) убирать суммы за счет ФБ - странное решение, на мой взгляд.
2. milov.aleksey 330 15.10.20 14:07 Сейчас в теме
(1) Алина, добрый день. Да, во всех больничных с кодом 09 с 18 сентября, после установки релиза 3.1.14.208. Исходное решение в модуле исходной процедуры(текстовый файл), куда добавили последний кусок кода без основной проверки используем ли мы вообще финансирование за счет бюджета.
 Процедура РассчитатьПособиеПоНетрудоспособности(СтрокиРасчета, ДополнительныеПараметры, ПрименяетсяСторнирование = Истина) Экспорт
	
	ПараметрыОплаты = ДополнительныеПараметрыРасчетаПособияПоНетрудоспособности();
	ЗаполнитьЗначенияСвойств(ПараметрыОплаты, ДополнительныеПараметры.ПараметрыРасчетаПособияПоНетрудоспособности);
	
	Если Не ЗначениеЗаполнено(ПараметрыОплаты.РайонныйКоэффициентРФНаНачалоСобытия)
		Или ПараметрыОплаты.РайонныйКоэффициентРФНаНачалоСобытия < 1 Тогда
		ПараметрыОплаты.РайонныйКоэффициентРФНаНачалоСобытия = 1;
	КонецЕсли;
	
	Если ТипЗнч(ПараметрыОплаты.РасчетПоПравилам2010Года) <> Тип("Булево") Тогда
		ПараметрыОплаты.РасчетПоПравилам2010Года = Ложь;
	КонецЕсли;
		
	НазначитьПособие = ПараметрыОплаты.НазначитьПособие;
	Если НазначитьПособие = Истина Тогда
		ПрименятьОграничениеДляПособийПоНС_ПЗ = (ПараметрыОплаты.ПричинаНетрудоспособности = Перечисления.ПричиныНетрудоспособности.ТравмаНаПроизводстве
											Или ПараметрыОплаты.ПричинаНетрудоспособности = Перечисления.ПричиныНетрудоспособности.Профзаболевание)
											И ПараметрыОплаты.ОграничениеПособия = Перечисления.ВидыОграниченияПособия.МаксимальныйРазмерЕжемесячнойСтраховойВыплаты;
											
		ОграниченияДляПособийПоНС_ПЗ = Новый Соответствие;
		Если ПрименятьОграничениеДляПособийПоНС_ПЗ Тогда
			
			ИзмеренияДаты = Новый ТаблицаЗначений;
			ИзмеренияДаты.Колонки.Добавить("Период", Новый ОписаниеТипов("Дата"));
			Для Каждого СтрокаТаблицы Из СтрокиРасчета Цикл
				ИзмеренияДаты.Добавить().Период = СтрокаТаблицы.ДатаНачала;
				ОграниченияДляПособийПоНС_ПЗ.Вставить(СтрокаТаблицы.ДатаНачала,0);
			КонецЦикла;
			
			Запрос = Новый Запрос;
			Запрос.МенеджерВременныхТаблиц = Новый МенеджерВременныхТаблиц;
			
			ПараметрыПостроения = ЗарплатаКадрыОбщиеНаборыДанных.ПараметрыПостроенияДляСоздатьВТИмяРегистраСрез();
			ПараметрыПостроения.ВсеЗаписи = Истина;
			
			ЗарплатаКадрыОбщиеНаборыДанных.СоздатьВТИмяРегистраСрезПоследних(
				"МаксимальныйРазмерЕжемесячнойСтраховойВыплаты",
				Запрос.МенеджерВременныхТаблиц,
				Ложь,
				ЗарплатаКадрыОбщиеНаборыДанных.ОписаниеФильтраДляСоздатьВТИмяРегистра(ИзмеренияДаты),
				ПараметрыПостроения);
			
			Запрос.Текст =
			"ВЫБРАТЬ
			|	МаксимальныйРазмер.Период КАК Период,
			|	МаксимальныйРазмер.Размер КАК Размер
			|ИЗ
			|	ВТМаксимальныйРазмерЕжемесячнойСтраховойВыплатыСрезПоследних­ КАК МаксимальныйРазмер";
			Выборка = Запрос.Выполнить().Выбрать();
			
			Пока Выборка.Следующий() Цикл
				ОграниченияДляПособийПоНС_ПЗ.Вставить(Выборка.Период, Выборка.Размер * 4);
			КонецЦикла;
		Иначе
			Для Каждого СтрокаТаблицы Из СтрокиРасчета Цикл
				ОграниченияДляПособийПоНС_ПЗ.Вставить(СтрокаТаблицы.ДатаНачала, 0);
			КонецЦикла;
		КонецЕсли;
		
	КонецЕсли;
	
	ПрименятьОграничениеПособияСнизуМРОТПоМесяцам = (
		ПараметрыОплаты.ПричинаНетрудоспособности = Перечисления.ПричиныНетрудоспособности.ПоУходуЗаРебенком);
	Если ПрименятьОграничениеПособияСнизуМРОТПоМесяцам Тогда
		КэшРасчетаПоМесяцам = Новый ТаблицаЗначений;
		КэшРасчетаПоМесяцам.Колонки.Добавить("СтрокаТаблицыРасчета");
		КэшРасчетаПоМесяцам.Колонки.Добавить("НачалоМесяца");
		КэшРасчетаПоМесяцам.Колонки.Добавить("Результат");
		КэшРасчетаПоМесяцам.Колонки.Добавить("РезультатБезЛьгот");
		КэшРасчетаПоМесяцам.Колонки.Добавить("ОграничениеПособияСнизу");
		Месяцы = Новый Массив;
	КонецЕсли;
	
	ДатаОтменыРасчета2010Года = УчетПособийСоциальногоСтрахованияКлиентСервер.ДатаНачалаРеформыСоцСтрахования();
	Для Каждого СтрокаТаблицы Из СтрокиРасчета Цикл
		
		Сторно = Ложь;
		Если ПрименяетсяСторнирование Тогда
			Сторно = СтрокаТаблицы.Сторно;
		КонецЕсли;
		
		СтрокаТаблицы.Результат = 0;
		СтрокаТаблицы.Дополнительно.Вставить("РезультатВТомЧислеЗаСчетФБ", 0);
		
		Если НазначитьПособие <> Истина Тогда
			// Нет данных для расчета.
			Продолжить;
		КонецЕсли;
		
		ОплачиваемоеВремя = РасчетЗарплаты.ЗначениеПоказателяПоИдентификатору(СтрокаТаблицы.Показатели, "КалендарныеДни");
		Если ОплачиваемоеВремя = Неопределено Тогда
			ОплачиваемоеВремя = 0;
		КонецЕсли;
		Если ПараметрыОплаты.ПричинаНетрудоспособности = Перечисления.ПричиныНетрудоспособности.ПоУходуЗаРебенком
			И ЗначениеЗаполнено(ПараметрыОплаты.ДатаНачалаПоловиннойОплаты)
			И СтрокаТаблицы.ДатаНачала >= ПараметрыОплаты.ДатаНачалаПоловиннойОплаты Тогда
			ПроцентОплаты = 50;
		Иначе
			ПроцентОплаты = ПараметрыОплаты.ПроцентОплаты;
		КонецЕсли;
		
		ПрименятьОграничениеМРОТом = ПараметрыОплаты.ОграничениеПособия = Перечисления.ВидыОграниченияПособия.ОграничениеВРазмереММОТ
			Или (СтрокаТаблицы.ДатаНачала >= ПараметрыОплаты.ДатаНарушенияРежима И ЗначениеЗаполнено(ПараметрыОплаты.ДатаНарушенияРежима));
		ПрименятьОграничениеМРОТомБезЛьгот = ПараметрыОплаты.ОграничениеПособияБезЛьгот = Перечисления.ВидыОграниченияПособия.ОграничениеВРазмереММОТ
			Или (СтрокаТаблицы.ДатаНачала >= ПараметрыОплаты.ДатаНарушенияРежима И ЗначениеЗаполнено(ПараметрыОплаты.ДатаНарушенияРежима));
		
		РасчетПоПравилам2010Года = ПараметрыОплаты.РасчетПоПравилам2010Года
			Или ПараметрыОплаты.ПериодРегистрации < ДатаОтменыРасчета2010Года
			Или ПараметрыОплаты.ДатаНачалаСобытия < ДатаОтменыРасчета2010Года;
		
		ТекущийРайонныйКоэффициент = 1;
		РайонныйКоэффициентРФ = РасчетЗарплаты.ЗначениеПоказателяПоИдентификатору(СтрокаТаблицы.Показатели, "РайонныйКоэффициентРФ");
		Если РайонныйКоэффициентРФ <> Неопределено Тогда
			ТекущийРайонныйКоэффициент = Макс(РайонныйКоэффициентРФ, 1);
		КонецЕсли;
		
		МРОТ = РасчетЗарплаты.ЗначениеПоказателяПоИдентификатору(СтрокаТаблицы.Показатели, "МРОТ");
		ТекущийМРОТ = МРОТ * ТекущийРайонныйКоэффициент;
		
		НормированноеОграничениеДляПособийПоНС_ПЗ = ОграниченияДляПособийПоНС_ПЗ[СтрокаТаблицы.ДатаНачала];
		
		НормаВремени = День(КонецМесяца(СтрокаТаблицы.ДатаНачала));
		Если ОплачиваемоеВремя < НормаВремени Тогда
			ОграничениеПособияМРОТом = Окр(Окр(ТекущийМРОТ / НормаВремени, 2) * ОплачиваемоеВремя, 2);
			НормированноеОграничениеДляПособийПоНС_ПЗ = Окр(Окр(НормированноеОграничениеДляПособийПоНС_ПЗ / НормаВремени, 2) * ОплачиваемоеВремя, 2);
		Иначе
			ОграничениеПособияМРОТом = Окр(ТекущийМРОТ,2);
		КонецЕсли;
		
		Если РасчетПоПравилам2010Года Тогда
			РазмерОграниченияДля2010года = Окр(РазмерОграниченияДля2010года() / 365, 2);
			Если ПараметрыОплаты.ОграничениеПособия = Перечисления.ВидыОграниченияПособия.БезОграничений Тогда
				Результат = ОплачиваемоеВремя * Окр(ПараметрыОплаты.СреднийДневнойЗаработок * ПроцентОплаты / 100, 2);
			Иначе
				Результат = ОплачиваемоеВремя * Окр(Мин(ПараметрыОплаты.СреднийДневнойЗаработок, РазмерОграниченияДля2010года) * ПроцентОплаты / 100, 2);
			КонецЕсли;
			
			// Ограничение пособия сверху
			Если ПрименятьОграничениеМРОТом Тогда
				Результат = Мин(Результат, ОграничениеПособияМРОТом);
			КонецЕсли;
			
			СтрокаТаблицы.Результат = Результат * ?(Сторно, -1, 1);
			
			Если ЗначениеЗаполнено(ПараметрыОплаты.ПроцентОплатыБезЛьгот) И ЗначениеЗаполнено(ПараметрыОплаты.ФинансированиеФедеральнымБюджетом) Тогда
				Если ПараметрыОплаты.ПричинаНетрудоспособности = Перечисления.ПричиныНетрудоспособности.ПоУходуЗаРебенком
						И ЗначениеЗаполнено(ПараметрыОплаты.ДатаНачалаПоловиннойОплаты)
						И СтрокаТаблицы.ДатаНачала >= ПараметрыОплаты.ДатаНачалаПоловиннойОплаты Тогда
					ПроцентОплаты = 50;
				Иначе
					ПроцентОплаты = ПараметрыОплаты.ПроцентОплатыБезЛьгот;
				КонецЕсли;

				Если ПараметрыОплаты.ОграничениеПособияБезЛьгот = Перечисления.ВидыОграниченияПособия.БезОграничений Тогда
					РезультатБезЛьгот = ОплачиваемоеВремя * Окр(ПараметрыОплаты.СреднийДневнойЗаработок * ПроцентОплаты / 100, 2);
				Иначе
					РезультатБезЛьгот = ОплачиваемоеВремя * Окр(Мин(ПараметрыОплаты.СреднийДневнойЗаработок, РазмерОграниченияДля2010года) * ПроцентОплаты / 100, 2);
				КонецЕсли;
				
				// Ограничение пособия сверху
				Если ПрименятьОграничениеМРОТомБезЛьгот Тогда
					РезультатБезЛьгот = Мин(РезультатБезЛьгот, ОграничениеПособияМРОТом);
				КонецЕсли;
				
				Если РезультатБезЛьгот < Результат Тогда
					СтрокаТаблицы.Дополнительно.РезультатВТомЧислеЗаСчетФБ = (Результат - РезультатБезЛьгот) * ?(Сторно, -1, 1);
					СтрокаТаблицы.ЗаписьРасчета.РезультатВТомЧислеЗаСчетФБ = СтрокаТаблицы.Дополнительно.РезультатВТомЧислеЗаСчетФБ;
				КонецЕсли;
			КонецЕсли;
		Иначе
			МинимальныйСреднедневнойЗаработок = МинимальныйСреднедневнойЗаработокДляСравненияСМРОТ(
				ПараметрыОплаты.МинимальныйСреднедневнойЗаработок, 
				ПараметрыОплаты.РайонныйКоэффициентРФНаНачалоСобытия,
				ПараметрыОплаты.ДатаНачалаСобытия);
			Если ПараметрыОплаты.СреднийДневнойЗаработок >= МинимальныйСреднедневнойЗаработок Тогда
				ДневноеПособие = Окр(ПараметрыОплаты.СреднийДневнойЗаработок * ПроцентОплаты / 100, 2);
				Результат = Окр(ОплачиваемоеВремя * ДневноеПособие, 2);
			Иначе
				ДневноеПособие = Окр(ПараметрыОплаты.МинимальныйСреднедневнойЗаработок * ПроцентОплаты / 100, 2);
				Результат = Окр(ОплачиваемоеВремя * ДневноеПособие * ПараметрыОплаты.РайонныйКоэффициентРФНаНачалоСобытия, 2);
			КонецЕсли;
			
			// Ограничение пособия сверху
			Если ПрименятьОграничениеМРОТом Тогда
				Результат = Мин(Результат, ОграничениеПособияМРОТом);
			ИначеЕсли ПрименятьОграничениеДляПособийПоНС_ПЗ Тогда
				Результат = Мин(Результат, НормированноеОграничениеДляПособийПоНС_ПЗ);
			КонецЕсли;
			
			// Ограничение пособия снизу
			ОграничениеПособияСнизу = ОграничениеПособияСнизуМРОТ(
				ПараметрыОплаты.ПричинаНетрудоспособности,
				СтрокаТаблицы.ДатаНачала,
				ОплачиваемоеВремя,
				РайонныйКоэффициентРФ,
				ПараметрыОплаты.ДоляНеполногоВремени,
				МРОТ);
			Если ОграничениеПособияСнизу > 0 Тогда
				Если ПрименятьОграничениеПособияСнизуМРОТПоМесяцам Тогда
					НачалоМесяца = НачалоМесяца(СтрокаТаблицы.ДатаНачала);
					Если Месяцы.Найти(НачалоМесяца) = Неопределено Тогда
						Месяцы.Добавить(НачалоМесяца);
					КонецЕсли;
					СтрокаТаблицыПоМесяцам = КэшРасчетаПоМесяцам.Добавить();
					СтрокаТаблицыПоМесяцам.СтрокаТаблицыРасчета = СтрокаТаблицы;
					СтрокаТаблицыПоМесяцам.НачалоМесяца = НачалоМесяца;
					СтрокаТаблицыПоМесяцам.Результат = Результат;
					СтрокаТаблицыПоМесяцам.РезультатБезЛьгот = 0;
					СтрокаТаблицыПоМесяцам.ОграничениеПособияСнизу = ОграничениеПособияСнизу;
				Иначе
					Результат = Макс(Результат, ОграничениеПособияСнизу);
				КонецЕсли;
			КонецЕсли;
			
			СтрокаТаблицы.Результат = Результат * ?(Сторно, -1, 1);
			
			// Часть пособия, финансируемая федеральным бюджетом.
			Если ЗначениеЗаполнено(ПараметрыОплаты.ПроцентОплатыБезЛьгот) И ЗначениеЗаполнено(ПараметрыОплаты.ФинансированиеФедеральнымБюджетом) Тогда
				Если ПараметрыОплаты.ПричинаНетрудоспособности = Перечисления.ПричиныНетрудоспособности.ПоУходуЗаРебенком
						И ЗначениеЗаполнено(ПараметрыОплаты.ДатаНачалаПоловиннойОплаты)
						И СтрокаТаблицы.ДатаНачала >= ПараметрыОплаты.ДатаНачалаПоловиннойОплаты Тогда
					ПроцентОплаты = 50;
				Иначе
					ПроцентОплаты = ПараметрыОплаты.ПроцентОплатыБезЛьгот;
				КонецЕсли;
				
				Если ПараметрыОплаты.СреднийДневнойЗаработок >= МинимальныйСреднедневнойЗаработок Тогда
					ДневноеПособие = Окр(ПараметрыОплаты.СреднийДневнойЗаработок * ПроцентОплаты / 100, 2);
					РезультатБезЛьгот = Окр(ОплачиваемоеВремя * ДневноеПособие, 2);
				Иначе
					ДневноеПособие = Окр(ПараметрыОплаты.МинимальныйСреднедневнойЗаработок * ПроцентОплаты / 100, 2);
					РезультатБезЛьгот = Окр(ОплачиваемоеВремя * ДневноеПособие * ПараметрыОплаты.РайонныйКоэффициентРФНаНачалоСобытия, 2);
				КонецЕсли;
				
				Если ПрименятьОграничениеМРОТомБезЛьгот Тогда
					РезультатБезЛьгот = Мин(РезультатБезЛьгот, ОграничениеПособияМРОТом);
				КонецЕсли;
				
				// Ограничение пособия снизу в размере МРОТ,
				// применяемое с 01.04.2020 в связи с эпидемией коронавируса,
				// не зависит от процентов стажа.
				Если ОграничениеПособияСнизу > 0 Тогда
					Если ПрименятьОграничениеПособияСнизуМРОТПоМесяцам Тогда
						СтрокаТаблицыПоМесяцам.РезультатБезЛьгот = РезультатБезЛьгот;
					Иначе
						РезультатБезЛьгот = Макс(РезультатБезЛьгот, ОграничениеПособияСнизу);
					КонецЕсли;
				КонецЕсли;
				
				Если РезультатБезЛьгот < Результат Тогда
					СтрокаТаблицы.Дополнительно.РезультатВТомЧислеЗаСчетФБ = (Результат - РезультатБезЛьгот) * ?(Сторно, -1, 1);
					СтрокаТаблицы.ЗаписьРасчета.РезультатВТомЧислеЗаСчетФБ = СтрокаТаблицы.Дополнительно.РезультатВТомЧислеЗаСчетФБ;
				КонецЕсли;
			КонецЕсли;
		КонецЕсли;
	КонецЦикла;
	
	//-=Н=- по заявке № 816268, Необходимо найти причину, исправить и чтоб в дальнейшем при расчете Больничного колонка "В том числе за счет фед.бюджета" не заполнялась.
	//Причина в том, что софинансирование с Фед.бюджетом вообще не используется.  
	//Милов А.В., 14 октября 2020 г. 14:06:22
	//Цель:	Исправление ошибки
	//---------------
	//-=Новый код=-
	//---------------
	ЕСЛИ Не (ЗначениеЗаполнено(ПараметрыОплаты.ПроцентОплатыБезЛьгот) И ЗначениеЗаполнено(ПараметрыОплаты.ФинансированиеФедеральнымБюджетом)) Тогда
		Возврат;
	КОНЕЦЕСЛИ;
	//-=К=-
	
	Если ПрименятьОграничениеПособияСнизуМРОТПоМесяцам И КэшРасчетаПоМесяцам.Количество() > 0 Тогда
		Для Каждого НачалоМесяца Из Месяцы Цикл
			
			Копия = КэшРасчетаПоМесяцам.Скопировать(Новый Структура("НачалоМесяца", НачалоМесяца));
			
			ИтогРезультат               = Копия.Итог("Результат");
			ИтогРезультатБезЛьгот       = Копия.Итог("РезультатБезЛьгот");
			ИтогОграничениеПособияСнизу = Копия.Итог("ОграничениеПособияСнизу");
			
			ЗаменитьРезультатНаМРОТ         = (ИтогОграничениеПособияСнизу > ИтогРезультат);
			ЗаменитьРезультатБезЛьготНаМРОТ = (ИтогОграничениеПособияСнизу > ИтогРезультатБезЛьгот);
			
			Если ЗаменитьРезультатНаМРОТ Или ЗаменитьРезультатБезЛьготНаМРОТ Тогда
				
				Для Каждого КэшСтроки Из Копия Цикл
					СтрокаТаблицы = КэшСтроки.СтрокаТаблицыРасчета;
					
					Сторно = ПрименяетсяСторнирование И СтрокаТаблицы.Сторно;
					
					Если ЗаменитьРезультатНаМРОТ Тогда
						КэшСтроки.Результат     = КэшСтроки.ОграничениеПособияСнизу;
						СтрокаТаблицы.Результат = КэшСтроки.ОграничениеПособияСнизу * ?(Сторно, -1, 1);
					КонецЕсли;
					
					Если ЗаменитьРезультатБезЛьготНаМРОТ Тогда
						КэшСтроки.РезультатБезЛьгот = КэшСтроки.ОграничениеПособияСнизу;
					КонецЕсли;
					
					Если КэшСтроки.РезультатБезЛьгот < КэшСтроки.Результат Тогда
						СтрокаТаблицы.Дополнительно.РезультатВТомЧислеЗаСчетФБ = (КэшСтроки.Результат - КэшСтроки.РезультатБезЛьгот) * ?(Сторно, -1, 1);
						СтрокаТаблицы.ЗаписьРасчета.РезультатВТомЧислеЗаСчетФБ = СтрокаТаблицы.Дополнительно.РезультатВТомЧислеЗаСчетФБ;
					КонецЕсли;
					
				КонецЦикла;
				
			КонецЕсли;
			
		КонецЦикла;
	КонецЕсли;
	
КонецПроцедуры
Показать
user750336; +1 Ответить
3. milov.aleksey 330 15.10.20 14:43 Сейчас в теме
(1) регистрация ошибки в техподе 1С https://bugboard.v8.1c.ru/error/000099430.
Описание стажа сотрудника, ребенка и больничного в ворд-файле.
По поводу расширения. Сделал самое очевидное, простое и модное: обнулить!
Аннотация &После, можно взять всю типовую процедуру с поправкой и заменить с помощью аннотации &Вместо
Прикрепленные файлы:
Описание ошибки 10226359.docx
user750336; +1 Ответить
4. user750336 15.10.20 16:28 Сейчас в теме
(3) Алексей, спасибо за подробный ответ с примером! Действительно, появляются эти суммы за счет ФБ, хотя и не во всех случаях. Но я бы всё-таки предложила немного по-другому эту ошибку исправить в последнем условии процедуры расчета пособия. Всё-таки, если весь новый алгоритм оборачивать в условие применения льгот, то ограничение МРОТом снизу совсем не будет применяться (то, что дорабатывали в расчете с 01.04.2020):
Если ПрименятьОграничениеПособияСнизуМРОТПоМесяцам И КэшРасчетаПоМесяцам.Количество() > 0 Тогда
		Для Каждого НачалоМесяца Из Месяцы Цикл
			
			Копия = КэшРасчетаПоМесяцам.Скопировать(Новый Структура("НачалоМесяца", НачалоМесяца));
			
			ИтогРезультат               = Копия.Итог("Результат");
			ИтогРезультатБезЛьгот       = Копия.Итог("РезультатБезЛьгот");
			ИтогОграничениеПособияСнизу = Копия.Итог("ОграничениеПособияСнизу");
			
			ЗаменитьРезультатНаМРОТ         = (ИтогОграничениеПособияСнизу > ИтогРезультат);
			ЗаменитьРезультатБезЛьготНаМРОТ = (ИтогОграничениеПособияСнизу > ИтогРезультатБезЛьгот);
			
			Если ЗаменитьРезультатНаМРОТ Или ЗаменитьРезультатБезЛьготНаМРОТ Тогда
				
				Для Каждого КэшСтроки Из Копия Цикл
					СтрокаТаблицы = КэшСтроки.СтрокаТаблицыРасчета;
					
					Сторно = ПрименяетсяСторнирование И СтрокаТаблицы.Сторно;
					
					Если ЗаменитьРезультатНаМРОТ Тогда
						КэшСтроки.Результат     = КэшСтроки.ОграничениеПособияСнизу;
						СтрокаТаблицы.Результат = КэшСтроки.ОграничениеПособияСнизу * ?(Сторно, -1, 1);
					КонецЕсли;
					
					//++ Исправление 15.10.2020
					Если ЗначениеЗаполнено(ПараметрыОплаты.ФинансированиеФедеральнымБюджетом) Тогда
					//-- Исправление 15.10.2020
					
					Если ЗаменитьРезультатБезЛьготНаМРОТ Тогда
						КэшСтроки.РезультатБезЛьгот = КэшСтроки.ОграничениеПособияСнизу;
					КонецЕсли;
					
					Если КэшСтроки.РезультатБезЛьгот < КэшСтроки.Результат Тогда
						СтрокаТаблицы.Дополнительно.РезультатВТомЧислеЗаСчетФБ = (КэшСтроки.Результат - КэшСтроки.РезультатБезЛьгот) * ?(Сторно, -1, 1);
						СтрокаТаблицы.ЗаписьРасчета.РезультатВТомЧислеЗаСчетФБ = СтрокаТаблицы.Дополнительно.РезультатВТомЧислеЗаСчетФБ;
					КонецЕсли;
					
					//++ Исправление 15.10.2020
					КонецЕсли;
					//-- Исправление 15.10.2020
					
				КонецЦикла;
				
			КонецЕсли;
			
		КонецЦикла;
	КонецЕсли;

Показать
5. milov.aleksey 330 15.10.20 16:43 Сейчас в теме
(4)Да, так лучше. Спасибо! Но вот &Вместо не сработало. У нас используется Профиль безопасности, а с ними "не дружат" расширения.
Оставьте свое сообщение

См. также

Формирование реестра сотрудников 65 лет и старше для ФСС, в соответствии с Постановлением Правительства РФ от 01.04.2020 № 402

Зарплата v8 v8::СПР ЗУП2.5 УПП1 ЗУП3.x Россия БУ ФОМС, ПФ, ФСС Бесплатно (free)

Внешняя обработка "Формирование реестра сотрудников 65 лет и старше для ФСС, в соответствии с Постановлением Правительства РФ от 01.04.2020 № 402.

09.04.2020    6285    0    salt7    35    

Загрузка распределённых сумм оплаты страховых взносов в 1С 8

Зарплата Внешние источники данных Обмен через XML Зарплата v8 ЗУП2.5 ЗКБУ Россия БУ НУ ФОМС, ПФ, ФСС Бесплатно (free)

Загрузка подготовленных во внешних, по отношению к 1С, программах сумм оплаты страховых взносов в документ "Сведения о страховых взносах и стаже застрахованных лиц (СЗВ-4, СЗВ-6) ". Добавлена обработка по замене информации в табличной части документа "Сведения о страховых взносах и стаже застрахованных лиц (СЗВ-4, СЗВ-6)".

23.07.2011    8329    0    Kapitan69    22    

Правила начального заполнения ЗУП 2.5 из Бухгалтерии 1.6. Обновленные

Обмен через XML Перенос данных из 1C8 в 1C8 Зарплата Зарплата v8 ЗУП2.5 БП1.6 Россия Бесплатно (free)

Правила обмена для начального заполнения ЗУП 2.5 из Бухгалтерии 1.6 Стандартная выгрузка + кадровые документы (прием, увольнение, кадровое перемещение) Была создана для версий БП 1.6.29.2 и ЗУП 2.5.31.4. Сделано с помощью конвертации 2.1.2.1

17.02.2011    11571    0    1cmax    3    

Выгрузка данных для ГАЗПРОМБАНКА!

Обмен с банком Банковские операции Зарплата Банковские операции Зарплата v8 ЗУП2.5 Россия Бесплатно (free)

Выгрузка и печать данных по сотрудникам для работы с ГАЗПРОМБАНКОМ.

31.01.2011    14411    0    DeniNikitin    6    

Формирование списка сотрудников на оформление банковских карт для Сбербанка

Универсальные печатные формы Обмен с банком Обработка документов Банковские операции Зарплата Банковские операции Зарплата v8 ЗУП2.5 Россия Бесплатно (free)

Внешняя обработка для 1С:8.1 ЗУП 2.5. Формирует список сотрудников (только работающих), на которых необходимо сделать банковские карты Сбербанка. Формирование списка возможно с отбором по периоду даты приема сотрудников.

10.11.2010    15566    0    pavel_pss    3    

Перенос данных Физических лиц из ЗУП в БП 1.6

Перенос данных из 1C8 в 1C8 Зарплата Управление персоналом (HRM) Зарплата Управление персоналом (HRM) v8 ЗУП2.5 БП1.6 Россия БУ Бесплатно (free)

Сделано для конечного пользователя. Для случаев, когда не ведется учет по сотрудникам в Бухгалтерии предприятия или не переносится отражение зарплаты из ЗУП. Настроено в конфигурации Конвертация данных 2.1. Переносит только: справочник ФизЛица, ФИО и паспортные данные и больше ничего. ВНИМАНИЕ! Правила требуют доработки.

18.10.2010    23592    0    IgorXml    9    

Обработка заполнения регистра сведений "ФИОФизлиц"

Обработка справочников Универсальные функции Зарплата Управление персоналом (HRM) Зарплата Управление персоналом (HRM) v8 ЗУП2.5 Бесплатно (free)

Обработка заполнения регистра сведений "ФИОФизлиц" на основании реквизита "Наименование" справочника "Физические лица".

24.08.2010    12233    0    Invodev    3    

Пересчет почтовых сборов в "Начисление зарплаты сотрудникам организации " ЗУП 8.1

Обработка документов Зарплата Зарплата v8 ЗУП2.5 Россия БУ Бесплатно (free)

Программа ЗУП по умолчанию считает почтовые сборы отдельно по каждому исполнительному листу, если по сотруднику несколько исполнительных листов, необходимо считать почтовый сбор исходя из общей суммы. Собственно это обработка и делает.

17.06.2010    9564    0    Najly    2    

Выгрузка на ПК в СберБанк для ЗБУ 8.1

Обработка документов Обмен с банком Банковские операции Зарплата Банковские операции Зарплата v8 ЗКБУ Бесплатно (free)

Столкнулся с удивительной, для меня, вещью: в "Зарплате и кадры для бюджетного учреждения" нет выгрузки данных о перечислениях зарплаты на пластик в СберБанк. И это при том, что значительная часть бюджетных учреждений открыли зарплатные счета именно в этом банке. Мнение 1С по этому поводу, если коротко: "Функциональность планируется реализовывать в конфигурации ББУ". А что же делать тем, у кого нет ББУ? Вот и сделал свою обработку на базе обработки из ЗУП 8, а точнее немного подправил типовую:

16.02.2010    13156    0    smooth    13    

Расчетные листки организации с рассылкой по почте

Зарплата Бухгалтерские Email Зарплата v8 ЗУП2.5 Россия БУ Бесплатно (free)

Расчетные листки организации с рассылкой по почте. Основана на стандартном отчете. Добавлена возможность рассылки расчетных листков в формате xls на почтовые ящики сотрудников.

21.10.2009    12214    0    Alltruist    19    

Расчет почтового сбора - неактуально с версии 1С УПП 1.2.30.1

Обработка документов Зарплата Зарплата v8 УПП1 Бесплатно (free)

В 1С УПП с версии 1.2.30.1 внедрен штатный механизм расчета почтового сбора, т.ч. данную обработку целесообразно использовать до данной версии УПП. Внешняя обработка по заполнению табличных частей для расчета почтового сбора в документах Начисление зарплаты работникам организации.

08.08.2009    8880    0    manserg    7    

Выгрузка зарплаты на пластиковые карточки Девон, Ак Барс банк

Обмен с банком Банковские операции Зарплата Банковские операции Зарплата v8 БП2.0 Россия БУ Бесплатно (free)

Позволяет формировать файлы выгрузки зарплаты на пластиковые карты для банков "Ак Барс Банк" и "Девон Кредит" на основании документов "Зарплата к выплате", "Платежное поручение" в ЗУП 2.5.

10.06.2009    13455    0    alexey85    5    

Распределение НДФЛ для ЗУП

Обработка документов Зарплата Управление персоналом (HRM) Зарплата Управление персоналом (HRM) v8 ЗУП2.5 БУ НУ НДФЛ Бесплатно (free)

Распределяет проводки по НДФЛ в документе "Отражение зарплаты в регламентированном учете" по резидентам нерезидентам по подразделениям и по ставкам налога. Возможно будет работать в УПП а может и в БП.

04.06.2009    13756    0    kwazi    7    

Заполнение табличной части документа "Оплаты праздничных и выходных дней" работавшими в эти дни

Обработка документов Зарплата Учет рабочего времени Зарплата Учет рабочего времени v8 ЗУП2.5 Россия БУ Бесплатно (free)

Подключаемая обработка заполнения табличной части документа "Оплаты праздничных и выходных дней" 1. по всем работавшим в праздничные и выходные дни; 2. По подразделению; 3. По одному сотруднику

21.05.2009    15864    0    WiseSnake    22    

Перепроведение кадровых документов (по сотруднику/ам) организации

Обработка документов Зарплата Зарплата v8 БП2.0 ЗУП2.5 УПП1 Россия БУ Бесплатно (free)

Выбираем сотрудника/ов, и по каждому перепроводим все кадровые документы организаций. УПП(1.2.22.3), ЗУП(2.5.14.3), Бухгалтерия Предприятия (1.6.15.5)

18.05.2009    8490    0    mosAdm    8    

Загрузка проводок из Камин 3 в БП 1.6

Перенос данных из 1C8 в 1C8 Зарплата Обмен через XML Зарплата v8 БП1.6 Россия БУ Бесплатно (free)

Альтернативная загрузка из Камин 3.0 в БП 1.6 Писалась по причине некоторой кривоватости оригинальной обработки. Основное отличие от "родной" Каминовской обработки в том, что настраиваются именно правила загрузки, а не результирующая таблица проводок.

07.05.2009    11163    0    shushkovka    7    

Количество месяцев и дней между датами (ЗУП)

Зарплата Универсальные обработки Зарплата v8 ЗУП2.5 Россия БУ Бесплатно (free)

Обработка подсчитывает количество месяцев и дней между 2-мя датами с учетом високосных

13.04.2009    16156    0    relax2105    21    

Исправление серии паспорта физического лица

Обработка справочников Зарплата Зарплата v8 ЗУП2.5 Бесплатно (free)

Правит серию паспорта на предмет добавления пробела.

09.04.2009    5253    0    Alex181    9    

Заполнение в БП базы изменения законодательства, связанной с зарплатным учетом в 2009 году

Обработка справочников Зарплата Зарплата v8 БП1.6 Россия БУ НДФЛ Бесплатно (free)

Для 1.6.12.4 делал на скорую руку. Смысл: по аналогии с ЗУП 2009 (которая была сделана по аналогии с ЗиК 2009) заполнить в БП базу изменений законодательства, связанных с зарплатным учетом.

11.02.2009    9015    0    IamAlexy    2    

Внешний модуль «Учет зарплаты» в конфигурации 1С Бухгалтерия 8.1

Обработка документов Зарплата Рабочее место Бухгалтерские Зарплата v8 БП2.0 Бесплатно (free)

Внешний модуль «Учет зарплаты» предназначен для учета табельных листков в документах «Табель учета рабочего времени» и формирование документов «Начисление зарплаты» в конфигурации 1С Бухгалтерия 8.1 редакция 1.6 (1.6.9.4).

16.01.2009    13924    0    NNNN    12    

Выгрузка зарплатного реестра для Сбербанка из 1С ЗУП 2.5 и Бухгалтерии Предприятия 2.0 в формате .txt

Обмен с банком Обработка документов Банковские операции Зарплата Банковские операции Зарплата v8 БП2.0 ЗУП2.5 Россия БУ Бесплатно (free)

Выгрузка зарплатного реестра для Сбербанка из 1С ЗУП 2.5, Бухгалтерия Предприятия 2.0 в формате .txt Добавлена загрузка лицевых счетов из файла, присланного Сбербанком.

05.01.2009    33059    0    goalkeeper    8    

Экспорт ведомостей на выплату из ЗиК 2.3 в БП 1.6

Перенос данных из 1С7.7 в 1C8.X Обработка документов Обмен через XML Зарплата Зарплата v8 1С7:ЗиК БП1.6 Россия БУ Бесплатно (free)

Правила обмена для выгрузки документов "выплаты зарплаты" из ЗиК 2.3 в БП 1.6 в документы "зарплата к выплате".

25.11.2008    12963    0    Valerich    9    

Запись ПП и РКО из ЗУП в БП посредством COM с нумерацией БП

Перенос данных из 1C8 в 1C8 Зарплата Зарплата v8 БП2.0 ЗУП2.5 Россия БУ Бесплатно (free)

Когда в ЗУП создается расходный кассовый ордер или платежное поручение, им необходимо присвоить номер из БП, дабы соблюсти нумерацию ПП и нумерацию в кассе. Так же необходимо эти документы из ЗУП в БП перенести, дабы там не создали другие документы с этими номерами.

17.10.2008    7902    0    Ygich    2    

Деактивация уволенных в справочнике "Сотрудники организаций"

Обработка справочников Зарплата Управление персоналом (HRM) Зарплата Управление персоналом (HRM) v8 ЗУП2.5 Бесплатно (free)

Снимает флаг "Актуальный" у тех сотрудников, которые уволены на текущий момент. Тем самым, сотрудник в списке справочника становится "серым" и невидимым при обычной работе пользователя.

21.07.2008    12968    0    Gaffer    15    

Автоматическое добавление недостающих ведущих и вытесняющих видов расчета для ЗУП 2.5 (8.1)

Универсальные обработки Зарплата Зарплата v8 ЗУП2.5 Россия БУ Бесплатно (free)

Обработка содержит экспортную процедуру, которая вызывается из модуля объекта вида расчета. Она определяет и заполняет состав недостающих вытесняющих и ведущих видов расчета. Сообщение "Неполный список вытесняющих/ведущих видов расчета...", таким образом, не появляется, и вид расчета беспрепятственно может быть записан. Можно работать как в интерактивном режиме (без "снятия замков"), так и вызывать функцию обработки из программных модулей.

29.03.2008    13598    0    boln    8    

Реестр начислений на пластиковые карты с формированием файла выгрузки в банк

Обмен с банком Бухгалтерские Банковские операции Зарплата Банковские операции Зарплата v8 ЗУП2.5 Россия БУ Бесплатно (free)

Реестр начислений на пластиковые карты с формированием файла выгрузки в банк для ЗУП на платформе 8.1.

29.01.2008    14348    0    diims    9    

Турбо Аванс

Обработка документов Обработка справочников Зарплата Зарплата v8 ЗУП2.5 Бесплатно (free)

Обработка позволяет установить суммы для начисления аванса, исходя из оклада сотрудника по основному месту работы. Можно назначить группам работников авансы процентом от оклада или суммой. Конфигурация ЗУП.

01.08.2007    3089    0    bikeylab    2    

Округление зарплаты в ведомости к выплате до целых

Обработка документов Зарплата Зарплата v8 ЗУП2.5 Россия БУ Бесплатно (free)

Простая обработка, встраиваемая в документ "Зарплата к выплате" конфигурации ЗУП. Делает округление суммы выдаваемой зарплаты до десятых, оставляя только рубли, отбрасывая копейки и "неэффективные" рубли, как, например, 10204 руб = 10 200руб. Невыданные переносятся сальдо на следующий месяц долгом за организацией.

01.07.2007    10129    0    whoscare    5    

ЗУП: Формулы, которые базируются на кодах расчетов

Универсальные обработки Зарплата Зарплата v8 ЗУП2.5 Россия Бесплатно (free)

ЗУП Формулы - формулы в зарплате без изменения конфигурации.

14.02.2007    5105    0    veslav    1